Nido Apple

Recibe ayuda de expertos

Registrate y pregunta

Es gratis y fácil

Recibe respuestas

Respuestas, votos y comentarios

Vota y selecciona respuestas

Recibe puntos, vota y da la solución

Pregunta

1voto

Problemas al exportar capas transparentes en iMovie

Hola a todos! Tengo el siguiente problema:

Estoy haciendo unos videos informativos con stop motion con iMovie. Como cada frame es un dibujo hecho a mano, necesito poner una segunda capa transparente para poner la información. Lo hice e iba todo bien (como sale en la imagen abajo), en el preview se veía perfecto.
https://ibb.co/fhLM8a

Al exportar el video y verlo, cada vez que aparecen las capas transparentes sobre los frames, se me manchan con una imagen de líneas rosas y blancas, como si hubiera un error de información solo en esa capa (en la imagen abajo). Los reviso en el programa y resulta que aparecen dañados los archivos con esas mismas líneas. Los vuelvo a poner, se ven bien, y al exportarlos sucede lo mismo.
https://ibb.co/cxOf1v

Por favor, ayuda!! Muchas gracias.

Peter comentado Sep 8

No se ven las imágenes, por favor sábelas a un servicio en el que todos las puedan ver.

Saludos.

Peter comentado Sep 8

Ahora si se ven. ¿Con que ajustes estas exportando?

Saludos.

TrinidadVial comentado Sep 8

Estoy exportando con calidad alta, y anchura 1080px. Mis imágenes transparentes tienen la calidad suficiente para que no se vea pixelada la información.

Peter comentado Sep 8

¿Pero en que formato? Hay que saber todos los ajustes que usas para exportar para ver si ahí puede estar el problema.

Saludos.

TrinidadVial comentado Sep 8

Estoy exportando con mp4, calidad alta, y 1080px 60 de resolución. Formato video y audio. Compresión "más rápida" (en vez de "más calidad").
Mi iMovie es el 10.1.2, no me da mucha más información al exportar.

Peter comentado Sep 8

¿Ya probaste con diferentes formatos y calidad?

TrinidadVial comentado Sep 8

Si, me sucede lo mismo.

Peter comentado Sep 8

La otra opción es que exportes tus PNG de forma diferente, también podría influir en ese aspecto, aunque sería raro.

En definitiva no hay muchas mas opciones que los formatos y compresión que utilices al exportar desde iMovie. Si pones un PNG de esos para descargar, hago una prueba para ver si me hace lo mismo.

Saludos.

TrinidadVial comentado Sep 8

Deben estar malos los png, porque ni siquiera puedo subirlos a internet, me sale "Error al subir". ¿Cómo puedo exportar mis png de manera segura? Yo hice los archivos en Photoshop.

TrinidadVial comentado Sep 8

Intenté arreglar los png y me funcionó mejor. Hay solo 1 frame que molesta, me quedo tranquila con eso.

Muchas gracias por tu ayuda!

Peter comentado Sep 8

Que bueno que se solucionó con eso!

Por favor publica abajo una respuesta con los pasos que seguiste, eso le ayudará a otros con el mismo problema y que la puedas seleccionar como respuesta correcta.

Saludos.

2 Respuestas

1voto

Ajmaq Puntos24760

Hola Trinidad,

Te cuento que esto no es ningun problema de formato o de las fotos... mirando charlas de otros usuarios en Apple support veo que es un problema del Imovie... este problema parece estar asociado a las Mac viejitas que tienen unas cartas de video mas antiguas y como Mac esta movien mucho mas processos de video de la CPU a los procesadores graficos de la mac se genera este tipo de problemas.

Uno de los usuarion intento lo siguiente y funciono con exito:

TrinidadVial comentado Sep 8

¡Muchas gracias por tu respuesta! ¿Qué hizo este usuario entonces?

Ajmaq comentado Sep 8

Disculpa.. me falto esa parte del mensaje..

  1. entras a Imovie y y haces un back up de tu projecto en "mys projectos"
  2. Luego le haces click al projecto para selecionarlo.
  3. Lo vas a Duplicar, puedes hacerlo con la tecla Command + D o si prefieres right click en la tab de arriba y le das Duplicar.
  4. Una vez Duplicado, abrelo y exportalo a ver que te sale.

Saludos.

TrinidadVial comentado Sep 8

Gracias Ajmaq: Voy a hacerlo inmediatamente y lo exporto. Me demoro una media hora en exportarlo completamente, ahí te respondo si me funcionó o no.

Mil gracias!

Ajmaq comentado Sep 8

Esperamos a que esto solucione el problema... si no podemos ver que se puede hacer ya qe conocemos el problema de la CPU, los porcessos y la aplicacion.

Una saludo.

TrinidadVial comentado Sep 8

No me funcionó! :(

2votos

TrinidadVial Puntos210

Hola,

Con la ayuda de los experto de NidoApple llegamos a una solución (no funcionó completamente, pero mejoró notablemente el problema)

Los png transparentes que estaba usando estaban modificados por illustrator, los pasé a photoshop y probablemente ahí se dañaron de alguna forma. Lo que hice fue hacer el png completamente en photoshop, incluyendo la informacion que tenía antes. De esta manera el png no venía tan dañado y al exportar la película en iMovie, desaparecieron casi del todo los errores en pantalla.

Si aún no les funciona, revisen que no estén muy grandes los png de tamaño, que también fue un factor.

Peter comentado Sep 9

Gracias por compartir la solución, por favor selecciona la respuesta como correcta.

Saludos.

Por favor, accede o regístrate para responder a esta pregunta.

¿Conoces alguien que puede responder?
¡Comparte esta pregunta!


...